Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble in Windows x64
04-01-2016, 03:30 PM,
Post: #1
Trouble in Windows x64
I'm trying to upgrade a system that communicates to a Casio register via Casio's CV-22 software from Windows XP. Everything works in XP using either a generic USB adapter or an ESL4-DB9.

First attempted upgrade was to Windows 10 x64 using the Windows 8 Lava ESL WESL 2015_01_13a setup. The CV-22 software works in Windows 10 x64 using the generic USB/RS-232 adapter, but we can not get it to work using the ESL4-DB9. When we try initiating communications the register sees the attempt and locks the keyboard, the lights flash a few times on the ESL4-DB9, and then we eventually get an error "4506 - Protocol or communication packet error" in the CV-22 software. We've tried every configuration and driver option we can find to no avail. The ports activate and install fine in Windows, communications start up, and then fail with the same error every time using the ESL4-DB9

We put a Hyper-V Windows XP virtual machine on the Windows 10 x64 computer, and installed the old manager/drivers and CV-22 software, and once again, everything works as expected inside the virtual machine.

We next tried Windows 7 x64 concluding that the Windows 8.1 drivers may not work for Windows 10. We get the same results in Windows 7 x64 as we do in Windows 10 x64. Communications are initiated, the register sees communications and locks the keyboard, we wait, we get the same error "4506 - Protocol or communication packet error".

Any ideas on getting the ESL4-DB9 to work in the CV-22 application on something newer than Windows XP? USB/RS-232 works fine, but we sometimes need access at longer distances than that will accommodate, and a virtual XP machine almost defeats the purpose of upgrading Windows.

The ESL4-DB9 firmware is 6.1.0 2007/03/29

Forum Jump:

Users browsing this thread: 1 Guest(s)