LAVA: Forums
[FAQ] USB-Serial Link in Windows 64 - Printable Version

+- LAVA: Forums (http://forum.lavalink.com)
+-- Forum: Support (http://forum.lavalink.com/forumdisplay.php?fid=43)
+--- Forum: USB to Serial (http://forum.lavalink.com/forumdisplay.php?fid=71)
+--- Thread: [FAQ] USB-Serial Link in Windows 64 (/showthread.php?tid=20947)



[FAQ] USB-Serial Link in Windows 64 - LavaSupport - 07-23-2015

Question:
Is my USB-Serial Link supported in a Windows 64-bit systems?

Answer:
Unfortunately due to Driver Signing Requirements of Windows 64-bit systems, support for LAVA's USB-Serial Link line is limited to 32-bit versions of Windows 2000 and later.  

At the present time there is no plan to expand the support for this product to include 64-bit operating systems.

Applies to:
  USB-Serial 2-232-DB9
  USB-Serial 4-232-DB9
  USB-Serial 4-232-DB9 Cabled


- Lava Support


RE: [FAQ] USB-Serial Link in Windows 64 - TomL_12953 - 09-28-2015

Note that "unsupported" doesn't necessarily mean "doesn't work". I'm using the USB-4-232-DB9 Cabled with 64-bit Windows 10 with no problem at all. I didn't need to install a driver. I just plugged the device in while my PC was running and Windows searched for, found and installed the correct drivers. The four ports showed up in Device Manager as COM1, 2, 3 and 4. I tested all four ports with serial devices and all work fine.
I have no connection with Lavalink other than being a satisfied customer.

Tom L


RE: [FAQ] USB-Serial Link in Windows 64 - LavaSupport - 10-01-2015

Hi Tom,

Thanks for the update, I hadn't had a chance to check the the USB-Serial Link with Windows 10 (64-bit) as of yet but I will hopefully be looking into it shortly.

As the USB-Serial Link requires a custom driver, all previous versions of Windows required driver signing in order to correctly install the hardware. I'm guessing Microsoft made a modification to their Driver Signing policy, though that wasn't something that would have expected.

Do you might letting me know which driver you installed? ... In addition to the OS Version of W10 you're running (cmd> systeminfo)?

- Lava Support